WebI graphomate extensions nicht mehr erreichbar - Häufige Ursachen

Bitte prüfen Sie, ob folgende Einstellungen richtig konfiguriert sind:

Benutzerdefinierte Elemente aus WebI werden nicht mehr erreicht, Test schlägt fehl

Dieses Problem betrifft folgende Versionen der Plattform, wenn die Testverbindung zum Services aufgerufen wird:

  • BI Platform Servers 4.2 SP8 patches 10, 11 and 12. Fehlerbehebung mit SP8 Patch 12 Hotfix 1.

  • BI Platform Servers 4.2 SP9 patch 4. Fehlerbehebung mit SP9 Patch 5.

Entsprechende SAP Note

Bitte führen Sie ein Upgrade durch, um die graphomate extension wieder als Benutzerdefinierte Elemente in WebI verwenden zu können.

Fehlerquellen bei der Installation/Update auf BOE 4.3+

  1. Ist die graphomate war-Datei auf dem Tomcat-Server gleich geschrieben wie in der URL des Services?

  2. Wurde der Tomcat Server neugestartet?

  3. Ist der graphomate Service auf der Whitelist hinterlegt? SAP Dokumentation
    Prüfen Sie bitte auch die Schreibweise der URL auf der Whitelist und der CMC, häufig ist ein fehlendes “/“ die Fehlerquelle.

  4. Ist das Cross-Site-Scripting aktiviert? SAP Dokumentation

Hilfreiche Seiten aus dem graphomate Handbuch

https://graphomate.atlassian.net/wiki/spaces/GFWI/pages/53870622 (auch Einrichten von SSL)

https://graphomate.atlassian.net/wiki/spaces/GFWI/pages/55050266

 

Extensions bleiben nach Update leer

Ursache kann sein, dass der Service im CMC anders benannt wurde, als mit der alten Version. Groß-/Kleinschreibung beachten!

Lösung: alten Bericht laden, Konsole öffnen, unter Quellen die Variable @serverId finden → hier steht wie der Service heißen sollte